Por qué a partir del 30 de septiembre algunos de tus dispositivos pueden quedarse sin conexión a Internet

Por qué a partir del 30 de septiembre algunos de tus dispositivos pueden quedarse sin conexión a Internet
1 comentario

La obsolescencia programada es una característica de muchos desarrollos tecnológicos a la que desgraciadamente nos hemos venido acostumbrando en múltiples sectores comerciales, con equipos que se estropean por completo, que dejan de funcionar parcialmente o pierden ciertas funcionalidades y opciones que en su día nos animaron a comprarlos.

Los dispositivos para el hogar inteligente, ordenadores, televisores, navegadores web y demás equipos conectados no son una excepción, con cambios en la configuración que muchas veces nos limitan sus posibilidades de uso.

no internet

El último ejemplo nos llega de la mano de Let's Encrypt, una organización sin ánimo de lucro que se dedica a emitir certificados raíz HTTPS con los que nuestros equipos son capaces de cifrar las conexiones al acceder a la Web y a ciertos servicios online.

Pero en unos días se producirá un cambio importante que podría ocasionar problemas de acceso a algunos usuarios a partir del 30 de septiembre de 2021.

El motivo es sencillo: el 30 de septiembre expira el certificado IdentTrust DST Root CA X3, un software que muchos ordenadores y equipos multimedia tienen instalado en su sistema operativo para acceder a la navegación web, necesitando de otro sistema equivalente y actualizado en nuestros dispositivos que realice dicha función si no queremos quedarnos sin poder acceder a servicios en la Red.

Image 6

En teoría no debería suponer ningún problema, siempre que tengamos nuestro software actualizado. Sin embargo, dado que este tipo de certificados suele instalarse con el lanzamiento de los equipos y utilizarse durante años, puede que si cuentas con un dispositivo muy antiguo que no hayas puesto al día en los últimos años te quedes sin poder acceder a Internet. Según podemos leer en la propia página de Let’s Encrypt:

Después del 30 de septiembre de 2021, sólo las plataformas que utilicen ISRG Root X1 (y no DST Root CA X3, que es el que se quedará obsoleto) podrán continuar validando los certificados de Let’s Encrypt

Image 7

En la web podemos encontrar también un listado con las plataformas que cumplen estos requisitos, soportando la versión más moderna ISRG Root X1, por lo que en teoría si tenemos uno de estos dispositivos y contamos con su sistema operativo actualizado, no deberíamos tener problemas:

  • Windows >= XP SP3
  • macOS >= 10.12.1
  • iOS >= 10 (iOS 9 no lo incluía)
  • iPhone 5 y superior puede actualizarse a iOS 10 para ser compatible
  • Android >= 7.1.1 (aunque Android >= 2.3.6 seguirá funcionando en algunos casos)
  • Mozilla Firefox >= 50.0
  • Ubuntu >= xenial / 16.04
  • Debian >= jessie / 8
  • Java 8 >= 8u141
  • Java 7 >= 7u151
  • NSS >= 3.26

Si por el contrario contamos con un dispositivo basado en alguna de estas plataformas pero con un sistema operativo más antiguo, no cumplirá con esos requisitos y probablemente a partir del 30 de septiembre tendrá problemas de acceso a la navegación web y a servicios online.

No obstante, habrá que esperar a que llegue esta fecha para conocer exactamente qué equipos se verán afectados por esta caducidad en el certificado.

Vía | Techcrunch
Más información | Let's Encrypt

Temas
Inicio